Cisco tips: непронумерованные IP-интерфейсы

Введение.

В этом документе рассматривается концепция непронумерованных IP-интерфейсов и приводится несколько примеров конфигурации. Команда конфигурации "ip unnumbered" позволяет Вам сделать возможным обработку IP на последовательном интерфейсе без назначения ему точного адреса. Это хороший способ сохранения сетевого и адресного пространства.

IP и непронумерованные IP

В маршрутизаторе Cisco каждый интерфейс сети IP, который не подключен постоянно к общей "шине", должен принадлежать к уникальной подсети. Так работает интерфейс IP. На основе сетевой информации, которая содержится в таблице маршрутизации IP, к любой уникально идентифицируемой сети IP, напрямую не подключенной к маршрутизатору, можно добраться, направив пакет к следующему транзитному адресу сети, подключенной напрямую Когда сеть конечного пункта назначения соединена с интерфейсом, напрямую подключенным к пункту назначения, пакет без труда можно доставить конечному хосту (host).

Таблица маршрутизации IP состоит из маршрутов. Эти маршруты являются или маршрутами "подсети", или маршрутами "основной сети". Каждый маршрут имеет от одного и более вероятных адресов "последующих транзитных пунктов", которые являются адресами сети, подключенной напрямую. Маршруты подсетей замкнуты внутри основной сети. На каждом конце основной сети подсети агрегируются в один маршрут основной сети и объявляются другим основным сетям. Это позволяет сохранять размер таблиц маршрутизации небольшим.

Примечание: Приведенная выше схема агрегирования предполагает использование традиционного протокола маршрутизации дистанционных векторов, таких как RIP (Протокол маршрутизации для сетей TCP/IP) или IGRP (Внутренний протокол маршрутизации шлюза).

Предположим, что сеть класса B разбита на подсети с 8-разрядными адресами. Каждый интерфейс в сети с последовательными линиями связи будет требовать отдельную подсеть. Так как каждая последовательная линия связи имеет лишь два узла, то остаются неиспользованными 252 адреса на каждой последовательной линии. Вот где могут пригодиться непронумерованные IP. Для любой последовательной линии "точка-точка" (point-to-point) или интерфейса "точка-точка" непронумерованные IP позволяют "позаимствовать" адрес у какого-то интерфейса локальной сети для использования в качестве исходного адреса для маршрутизируемых обновлений (Update) и пакетов с этого интерфейса. Сеть полностью используется, и ценная область адресов не увеличивается.

Как же обновляется таблица маршрутизации? Обычно маршрутизатор, получающий пакет обновлений, будет использовать исходный адрес маршрутизируемого обновления в качестве следующего транзитного пункта, так как нам обеспечивается прямое подключение к сетям, посылающим это обновление (с помощью одного интерфейса одного типа сети).

Однако, так как удаленная последовательная линия "позаимствовала" адрес у удаленной локальной сети (LAN), нам не обеспечивается прямое подключение исходного адреса к маршрутизатору, получающему обновление. Поэтому, вместо простого перехода к адресу следующего транзитного участка на базе исходного адреса обновления, маршруты, опознанные по имени непронумерованного IP интерфейса, включаются в таблицу маршрутизации в качестве интерфейсных маршрутов. Это означает, что недействительный адрес следующего транзитного пункта, будет обходиться, а использоваться будет имя интерфейса, с которого мы получили данное обновление. Поэтому непронумерованные

IP имеют смысл лишь для линий связи "точка-точка".

Примеры конфигурации.

Пример 1. С каждой стороны последовательной линии связи мы имеем ту же самую основную сеть с различными подсетями.

M/S1 - Основная сеть M/подсеть 1.

M/S2 - Основная сеть M/подсеть 2.

7000 Configuration:

interface Ethernet3/0

ip address 171.68.178.196 255.255.255.192

interface Serial4/3

ip unnumbered Ethernet3/0

router igrp 10

network 171.68.0.0

2500 Configuration:

interface Ethernet 0

ip address 171.68.179.1 255.255.255.192

interface Serial 0

ip unnumbered Ethernet0

router igrp 10

network 171.68.0.0

7000 Results:

FRCS7-2# sh ip route 171.68.0.0

Routing entry for 171.68.0.0 (mask 255.255.255.192), 50 known subnets

Attached (1 connections)

Redistributing via igrp 10

I 171.68.174.64 [100/1310] via 171.68.178.193, 00:01:02, Ethernet3/0

I 171.68.170.64 [100/1310] via 171.68.178.193, 00:01:02, Ethernet3/0

I 171.68.231.0 [100/1330] via 171.68.178.193, 00:01:02, Ethernet3/0

I 171.68.179.0 [100/1310] via 171.68.179.1, 00:01:02, Serial4/3

I 171.68.230.0 [100/1330] via 171.68.178.193, 00:01:02, Ethernet3/0

.....

FRCS7-2#ping 171.68.179.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 171.68.179.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms

2500 Results:

S251-1#sh ip route 171.68.0.0

Routing entry for 171.68.0.0 (mask 255.255.255.192), 50 known subnets

Attached (1 connections)

Known via "connected", distance 0, metric 0 (connected)

Tag 0

Redistributing via igrp 10

.....

I 171.68.174.64 [100/8786] via 171.68.178.196, 0:00:29, Serial0

I 171.68.170.64 [100/8786] via 171.68.178.196, 0:00:29, Serial0

I 171.68.231.0 [100/8806] via 171.68.178.196, 0:00:29, Serial0

I 171.68.230.0 [100/8806] via 171.68.178.196, 0:00:29, Serial0

I 171.68.178.192 [100/8806] via 171.68.178.196, 0:00:29, Serial0

.....

FRCS251-1#ping 171.68.178.196

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 171.68.178.196, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms

Заключение: В этом сценарии поддерживается маршрутная информация о подсетях.

Пример 2. На каждой стороне последовательной линии связи мы имеем различные основные сети без подсетей.


M/NS - Основная сеть M/Нет подсетей.

K/NS - Основная сеть K/Нет подсетей.

7000 Configuration:

interface Ethernet3/0

ip address 171.68.178.196 255.255.0.0

interface Serial4/3

ip unnumbered Ethernet3/0

router igrp 10

network 171.68.0.0

2500 Configuration:

interface Ethernet 0

ip address 172.68.1.1 255.255.0.0

interface Serial 0

ip unnumbered Ethernet0

router igrp 10

network 172.68.0.0

7000 Results:

FRCS7-2#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate

default

Gateway of last resort is not set

I 172.68.0.0 [100/8576] via 172.68.1.1, 00:00:02, Serial4/3

C 171.68.0.0 is directly connected, Ethernet3/0

FRCS7-2#ping 172.68.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.68.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms

2500 Results:

FRCS251-1#sh ip route

Codes: I - IGRP derived, R - RIP derived, H - HELLO derived, O - OSPF derived

C - connected, S - static, E - EGP derived, B - BGP derived

i - IS-IS derived

* - candidate default route, IA - OSPF inter area route

E1 - OSPF external type 1 route, E2 - OSPF external type 2 route

L1 - IS-IS level-1 route, L2 - IS-IS level-2 route

Gateway of last resort is not set

C 172.68.0.0 is directly connected, Ethernet0

I 171.68.0.0 [100/8576] via 171.68.178.196, 0:00:01, Serial0

FRCS251-1#ping 171.68.178.196

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 171.68.178.196, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms

Заключение: Информация основной сети поддерживается непронумерованной линией связи "точка-точка".

Пример 3. На одной стороне последовательной линии связи мы имеем основную сеть с подсетью, а на другой стороне - основную сеть без подсетей.







M/S1 - Основная сеть M/Подсеть 1.

K/NS - Основная сеть K/Нет подсетей.

7000 Configuration:

interface Ethernet3/0

ip address 171.68.178.196 255.255.255.192

interface Serial4/3

ip unnumbered Ethernet3/0

router igrp 10

network 171.68.0.0

2500 Configuration:

interface Ethernet 0

ip address 172.68.1.1 255.255.0.0

interface Serial 0

ip unnumbered Ethernet0

router igrp 10

network 172.68.0.0

7000 Results:

FRCS7-2# sh ip route 172.68.0.0

Routing entry for 172.68.0.0 (mask 255.255.0.0)

Known via "igrp 10", distance 100, metric 8576

Redistributing via igrp 10

Advertised by igrp 10

Last update from 172.68.1.1 on Serial4/3, 00:00:58 ago Routing Descriptor Blocks:

172.68.1.1, from 172.68.1.1, 00:00:58 ago, via Serial4/3

Route metric is 8576, traffic share count is 1

Total delay is 21000 microseconds, minimum bandwidth is 1544 Kbit

Reliability 128/255, minimum MTU 1500 bytes

Loading 1/255, Hops 0

S7-2#ping 172.68.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.68.1.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

2500 Results:

FRCS251-1#sh ip route 171.68.0.0

Routing entry for 171.68.0.0 (mask 255.255.255.255), 49 known subnets

Known via "igrp 10", distance 100, metric 8786

Tag 0

Redistributing via igrp 10

Last update from 171.68.178.196 on Serial0, 00:00:36 seconds ago

I 171.68.174.64 [100/8786] via 171.68.178.196, 0:00:36, Serial0

I 171.68.170.64 [100/8786] via 171.68.178.196, 0:00:36, Serial0

I 171.68.231.0 [100/8806] via 171.68.178.196, 0:00:36, Serial0

I 171.68.230.0 [100/8806] via 171.68.178.196, 0:00:36, Serial0

I 171.68.187.64 [100/8696] via 171.68.178.196, 0:00:36, Serial0

I 171.68.159.64 [100/9696] via 171.68.178.196, 0:00:36, Serial0

I 171.68.158.64 [100/9696] via 171.68.178.196, 0:00:36, Serial0

Как мы можем видеть, "7000" послал обновления, содержащие его подсети, но "2500" не ожидает увидеть подсетей в получаемых обновлениях. В результате "2500" помечает эти обновления как опознаваемые с маской подсети 255.255.255.255, которая делает сеть похожей на маршруты хоста. И так как нет ни одного маршрута для 171.68.178.196, следующий ping не будет работать:

S251-1#ping 171.68.178.196

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 171.68.178.196, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

Решение: "7000" знает, как попасть к сетевому адресу

172.68.0.0, но "2500" потерял информацию, рассматривая обновления сети как маршруты хоста. Такой статический маршрут в "2500", как ip route 171.68.0.0 s 0 - является "хитрым приемом", который нам поможет.

FRCS251-1#sh ip route 171.68.0.0

Routing entry for 171.68.0.0 (mask 255.255.0.0), 50 known subnets

Attached (1 connections)

Variably subnetted with 2 masks

Known via "igrp 10", distance 100, metric 8786 (connected)

Tag 0

Redistributing via igrp 10

Last update from 171.68.178.196 on Serial0, 0:00:26 seconds ago

S 171.68.0.0 is directly connected, Serial0

I 171.68.174.64 255.255.255.255

[100/8786] via 171.68.178.196, 0:00:26, Serial0

I 171.68.170.64 255.255.255.255

[100/8786] via 171.68.178.196, 0:00:26, Serial0

FRCS251-1#ping 171.68.178.196

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 171.68.178.196, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

Заключение: Информация подсети потеряна, потому что ее рассматривали как маршрут хоста. Добавьте статический маршрут для исправления такой ситуации.

Пример 4.

На обеих сторонах последовательной линии связи мы имеем две различных основных сети с соответствующими подсетями.














M/S1 - Основная сеть M/Подсеть 1.

K/S1 - Основная сеть К/Подсеть 1.

7000 Configuration:

interface Ethernet3/0

ip address 171.68.178.196 255.255.255.192

interface Serial4/3

ip unnumbered Ethernet3/0

router igrp 10

network 171.68.0.0

2500 Configuration:

interface Ethernet 0

ip address 172.68.1.1 255.255.255.192

interface Serial 0

ip unnumbered Ethernet0

router igrp 10

network 172.68.0.0

7000 Results:

FRCS7-2#sh ip route 172.68.0.0

Routing entry for 172.68.0.0 (mask 255.255.255.255),

Redistributing via igrp 10

Advertised by igrp 10

I 172.68.254.0 255.255.255.255

[100/8576] via 172.68.1.1, 00:01:06, Serial4/3

I 172.68.1.0 255.255.255.255

[100/8576] via 172.68.1.1, 00:01:06, Serial4/3

FRCS7-2#ping 172.68.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.68.1.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

2500 Results:

FRCS251-1#sh ip route 171.68.0.0

Routing entry for 171.68.0.0 (mask 255.255.255.255), 50 known subnets

Known via "igrp 10", distance 100, metric 8786

Tag 0

Redistributing via igrp 10

Last update from 171.68.178.196 on Serial0, 0:01:17 seconds ago

I 171.68.178.192 [100/8786] via 171.68.178.196, 0:01:17, Serial0

I 171.68.174.64 [100/8786] via 171.68.178.196, 0:01:17, Serial0

I 171.68.170.64 [100/8786] via 171.68.178.196, 0:01:17, Serial0

I 171.68.231.0 [100/8806] via 171.68.178.196, 0:01:17, Serial0

I 171.68.230.0 [100/8806] via 171.68.178.196, 0:01:17, Serial0

....

FRCS251-1# ping 171.68.178.196

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 171.68.178.196, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

Решение: Это усложненный вариант Примера 3. Для разрешения данной проблемы мы применяем статические маршруты к обоим концам последовательной линии:

7000: ip route 172.68.0.0 s 4/3

2500: ip route 171.68.0.0 s 0

7000 Results:

FRCS7-2#ping 172.68.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.68.1.1, timeout is 2 secs:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

2500 Results:

FRCS251-1#ping 171.68.178.196

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 171.68.178.196, timeout is 2 secs:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms

Заключение: Как и в Примере 3, информация подсети оказалась потерянной, потому что рассматривалась как маршрут хоста. Добавьте статические маршруты для исправления ситуации.

 

ООО "Новаком" тел./факс (343) 263-74-66 (многоканальный),   info@novacom.ru