Cisco Tips: Конфигурирование соединения с помощью прозрачного моста

Введение.

Этот документ поможет Вам конфигурировать соединение с помощью прозрачного моста. Мы начнем с общего описания соединений с помощью мостов, а затем предоставим Вам подробную информацию о соединении с помощью прозрачного моста, а также приведем несколько примеров конфигурации.

Соединение с помощью мостов.

Мосты - это устройства, которые позволяют локальным сетям (LAN) связываться и обмениваться данными. Существует четыре вида соединения с помощью мостов:

  • Соединение с помощью прозрачного моста - применяется главным образом для соединения сетей Ethernet и в основном используется для соединения сетей с одинаковой средой (топологией, монтажом, протоколом связи). Мост хранит таблицу адресов узлов-отправителей и внешних интерфейсов.
  • Соединение с помощью моста с маршрутизацией источника - применяется главным образом для соединения кольцевых сетей с эстафетным доступом Token Ring. Мосты только передают фреймы (пакеты данных) на основе индикатора маршрутизации, находящегося во фрейме. Конечные узлы отвечают за задание и ведение таблицы адресов узлов-отправителей и индикатора маршрутизации.
  • Соединение с помощью трансляционного моста - применяется для соединения сетей с различной средой и обмена данными между ними. Такие соединения чаще всего применяются для соединения Ethernet и FDDI (сети с топологией кольца и оптоволоконным кабелем) или Token Ring и Ethernet.
  • Соединение с помощью трансляционного моста с маршрутизацией источника - сочетает в себе маршрутизацию источника с передачей через прозрачный мост, что позволяет соединять сети Ethernet и Token Ring. (Трансляционные мосты без индикаторов маршрутизации между Token Ring и Ethernet также называются Прозрачными мостами с маршрутизацией источника).

Мосты функционируют на уровне обмена данными и управляют потоком данных, обрабатывают ошибки передачи, обеспечивают физическую адресацию и управляют доступом к физической среде. Мосты анализируют входящие фреймы, принимают решения о направлении фреймов (на основе информации, находящейся во фреймах) и направляют фреймы по назначению. Иногда, например, в мостах с маршрутизацией источника, фрейм содержит все описание маршрута назначения. В других случаях, например в прозрачных мостах, фреймы пересылаются от одного транзитного участка до другого к пункту назначения.

Мосты могут быть как удаленными, так и локальными. Локальные мосты обеспечивают прямое соединение большого числа сегментов локальной сети в одной и той же зоне. Удаленные мосты соединяют сегменты локальной сети различных зон, обычно с помощью телекоммуникационных линий связи.

Соединение с помощью прозрачного моста.

Алгоритм остовного дерева (STA) - важнейшая часть прозрачного моста. Алгоритм STA применяется для динамичного обнаружения подсети, не имеющей циклов, в топологии сети. Для этого STA задает мостовым портам, которые могли бы в активном состоянии создавать циклы, режим standby (резерв) или blocking (блокировка). Заблокированные порты могут активизироваться, если основной порт отказывает, таким образом обеспечивается резервная поддержка. Более подробную информацию можно найти в спецификации IEEE 802.1d.

Расчет остовного дерева происходит, когда включается мост, и всякий раз, когда обнаруживается изменение в топологии сети. Сообщения, заданные в конфигурации, называемые Bridge Protocol Data Units - BPDUs (пакет данных для инициализации связи между устройствами по протоколу остовного дерева) запускает расчет. Эти сообщения выдаются с постоянным интервалом, обычно 1-4 секунды.

Для понимания принципа работы, рассмотрим примеры:

Если бы B1 был единственным мостом, все бы функционировало отлично, но так как у нас есть еще мост B2, появляется два пути связи между двумя сегментами. Такая схема называется сетью с мостовыми циклами. Без алгоритма STA передача от хоста (host) сети LAN1 будет приниматься обоими мостами, а затем и B1, и B2 будут передавать то же самое сообщение в сеть LAN2. После этого оба моста (и B1, и B2) будут считать, что этот хост соединяется с LAN2. Кроме основной проблемы связуемости, передача сообщений в сети с циклами может вызвать проблемы с пропускной способностью сети.

Однако при наличии алгоритма STA, когда B1 и B2 начинают работу, они оба посылают сообщения BPDU, в которых содержится информация, определяющая, какой из мостов является корневым. Если корневым является мост B1, он станет назначенным мостом для обеих сетей - LAN1 и LAN2. B2 не будет передавать никаких пакетов от LAN1 к KAN2, пока его порты будет находиться в состоянии блокировки. Если B1 откажет, B2 не будет получать от B1 ожидаемых сообщений BPDU, поэтому B2 выдаст новое сообщение BPDU, которое вновь запустит алгоритм расчета STA. B2 станет корневым мостом, и траффик будет осуществляться через мост B2.

  • Программное обеспечение, разработанное Cisco для соединения с помощью прозрачных мостов, обладает следующими свойствами:
  • Соответствует стандарту IEEE 802.1d.
  • Предоставляет два протокола остовного дерева: формат BPDU стандарта IEEE и старый формат DEC, таким образом обеспечивается обратная совместимость с цифровыми и другими мостами локальных сетей.
  • Обеспечивает фильтрацию на базе адреса MAC (Управление доступом к среде), типа протокола и кода вендора.
  • Группирует последовательные линии связи в монтажные группы для баланса загрузки и увеличения резервных возможностей.
  • Обеспечивает возможность работать: с протоколом X.25 (Коммуникационный протокол между общедоступными сетями), в сети Frame Relay (Ретрансляция фрейма), в среде технологии SMDS (Служба коммутации многомегабитовых данных) и с протоколом PPP (Протокол "точка-точка").
  • Обеспечивает компрессию фреймов в протоколе LAT (Транспортный протокол для терминального сервера).
  • Позволяет рассматривать интерфейсы протоколов IP, IPX и т.п. как одну логическую сеть, таким образом домены мостов могут связываться с доменами маршрутизаторов.

Примеры конфигурации.

Приведенные примеры демонстрируют только те команды, которые требуются для соединения с помощью прозрачного моста, а не для поддержки протокола IP и других протоколов.

Пример # 1: Простое соединение с помощью прозрачного моста.

В этом примере в сеть LAN1 включено несколько персональных компьютеров, размещенных на одном этаже. В сети LAN2 также большое количество персональных компьютеров и несколько серверов, размещенных на другом этаже. Системы на каждой LAN используют либо протоколы IP, IPX, либо DECNET. Большую часть траффика можно маршрутизировать, но есть несколько прикладных систем, которые разработаны с собственными протоколами и которые нельзя маршрутизировать. Такой траффик нужно направлять через мост например, NetBIOS (Базовая сетевая система ввода-вывода) и LAT.

Примечание: До выпуска программного обеспечения Cisco IOS версии 11.0 один маршрутизатор не мог выполнять для одного протокола функции и маршрутизатора и моста. Версия Cisco IOS

11.0 позволяет для одного протокола одним интерфейсам выполнять функции моста, а другим - маршрутизатора. Однако такие интерфейсы не могут передавать траффик друг другу. Версия Cisco IOS 11.2 позволяет одновременно выполнять функции моста и маршрутизатора для протоколов и передавать траффик интерфейсов друг другу.

Interface ethernet 0

bridge group 1

Interface ethernet 1

bridge group 1

bridge group 1 protocol ieee

В этом примере стандарт IEEE 802.1d - протокол остовного дерева. Если каждый мост в сети является моделью Cisco, примените команду "bridge group 1 protocol ieee" ко всем маршрутизаторам. Если в сети используются различные модели мостов, воспользуйтесь старым мостовым форматом DEC, разработанным корпорацией Digital Equipment Corporation, а затем примените команду "bridge group 1 protocol dec" для обратной совместимости. Так как остовные деревья IEEE и DEC не совместимы, смешение этих протоколов в сети может привести к непредсказуемым результатам.

Пример # 2: Соединение с помощью прозрачного моста и многомостовых групп.


 

В этом примере маршрутизатор функционирует как два различных моста: один - между LAN1 и LAN2, другой - между LAN3 и LAN4. Для фреймов с LAN1 маршрутизатор выполняет функции моста к LAN2, но не к LAN3 или LAN4, и наоборот. Другими словами, фреймы пропускаются через мост только интерфейсами одной и той же группы. Это групповое свойство обычно используется для разделения сетей или пользователей.

interface ethernet 0

bridge group 1

interface ethernet 1

bridge group 1

interface ethernet 2

bridge group 2

interface ethernet 3

bridge group 2

bridge group 1 protocol ieee

bridge group 2 protocol dec

Пример # 3: Соединение с помощью моста в глобальной сети (Wide Area Network)

В этом примере две локальных сети LAN соединяются с помощью

высокоскоростной арендуемой линии T1.

Router A Router B

---- ----

Interface ethernet 0 Interface ethernet 0

bridge-group 1 bridge-group 1

Interface serial 0 Interface serial 0

bridge-group 1 bridge-group 1

bridge group 1 protocol ieee bridge group 1 protocol ieee

Пример # 4: Соединение с помощью удаленного прозрачного моста в среде протокола X.25

В этом примере используется та же топология, что и в предыдущем Примере 3, но вместо арендованной линии, соединяющей два маршрутизатора, будем считать, что маршрутизаторы Router A и Router B соединяются средой протокола X.25.

Router A Router B

---- ----

Interface ethernet 0 Interface ethernet 0

bridge-group 1 bridge-group 1

Interface serial 0 Interface serial 0

encapsulation x25 encapsulation x25

x25 address 31370019027 x25 address 31370019134

x25 map bridge 31370019134 x25 map bridge 31370019027

broadcast broadcast

bridge-group 1 bridge-group 1

bridge group 1 protocol ieee bridge group 1 protocol ieee

Пример # 5 : Соединение с помощью удаленного прозрачного моста в сети Ретрансляции фреймов (Frame Relay) без мультиотправки.

В этом примере используется та же топология, что и в примере 3, но вместо арендованной линии, соединяющей два маршрутизатора, будем считать, что маршрутизаторы Router А и Router B соединяются сетью Public Frame Relay. Программное обеспечение для функционирования мостов в сети Frame Relay использует тот же самый алгоритм остовного дерева, но оно позволяет инкапсулировать пакеты для передачи по всей сети Frame Relay. Команды специфицируют Internet для распределения адресов DLCI (Идентификатор логического соединения в сетях с ретрансляцией кадров) и ведут таблицу как для Ethernet, так и для идентификаторов DLCI.

Router A Router B

---- ----

Interface ethernet 0 Interface ethernet 0

bridge-group 1 bridge-group 1

Interface serial 0 Interface serial 0

encapsulation frame-relay encapsulation frame-relay

frame-relay map bridge 25 frame-relay map bridge 30

broadcast broadcast

bridge-group 1 bridge-group 1

group 1 protocol dec bridge group 1 protocol dec bridge

Пример # 6 : Соединение с помощью удаленного прозрачного моста в сети Frame Relay с мультиотправкой

В этом примере используется та же топология, что и в Примере 5, но здесь сеть Frame Relay поддерживает средства мультиотправки. Средства мультиотправки распознают другие мосты в сети, что позволяет исключить команду распределения идентификаторов Frame Relay.

Router A Router B

---- ----

Interface ethernet 0 Interface ethernet 0

bridge-group 2 bridge-group 2

Interface serial 0 Interface serial 0

encapsulation frame-relay encapsulation frame-relay

bridge-group 2 bridge-group 2

bridge group 2 protocol dec bridge group 2 protocol dec

Пример # 7 : Соединение с помощью удаленного прозрачного моста в сети Frame Relay с множеством подинтерфейсов.

Для использования подинтефейса, Вы должны задать операторы мостовой группы как для подинтерфейса, так и для основного интерфейса.

Router A Router B

---- ----

interface ethernet 0 interface ethernet 0

bridge-group 2 bridge-group 2

interface serial 0 interface serial 0

encapsulation frame-relay encapsulation frame-relay

bridge-group 2 bridge-group 2

! !

interface Serial0.1 interface Serial0.1

point-to-point point-to-point

frame-relay interface-dlci 101 frame-relay interface-dlci 100

bridge-group 2 bridge-group 2

! !

interface Serial0.2 interface Serial0.2

point-to-point point-to-point

frame-relay interface-dlci 103 frame-relay interface-dlci 103

bridge-group 2 bridge-group 2

bridge group 2 protocol dec bridge group 2 protocol dec

Пример # 8: Соединение с помощью удаленного прозрачного моста в среде технологии SMDS (Служба коммутации многобитовых данных)

Router A Router B

---- ----

Interface ethernet 0 Interface ethernet 0

bridge-group 2 bridge-group 2

Interface Hssi0 Interface Hssi0

encapsulation smds encapsulation smds

smds address c449.1812.0013 smds address c448.1812.0014

smds multicast BRIDGE smds multicast BRIDGE

e449.1810.0040 e449.1810.0040

bridge-group 2 bridge-group 2

bridge group 2 protocol dec bridge group 2 protocol dec

Пример # 9: Соединение с помощью удаленного прозрачного моста и монтажной группы.

При нормальной работе параллельные сегменты сети не могут выполнять траффик одновременно. Это необходимо для предотвращения зацикливания фреймов. Однако в случае последовательных линий связи Вам может понадобиться увеличить пропускную способность с помощью большого количества параллельных последовательных линий связи. Для этого можно использовать опцию "circuit-group".


Router A Router B

---- ----

Interface ethernet 0 Interface ethernet 0

bridge-group 2 bridge-group 2

Interface serial0 Interface serial0

bridge-group 2 bridge-group 2

bridge-group 2 circuit-group 1 bridge-group 2 circuit-group 1

Interface serial1 Interface serial1

bridge-group 2 bridge-group 2

bridge-group 2 circuit-group 1 bridge-group 2 circuit-group 1

Interface serial2 Interface serial2

bridge-group 2 bridge-group 2

bridge-group 2 circuit-group 1 bridge-group 2 circuit-group 1

bridge group 2 protocol dec bridge group 2 protocol dec

Балансировка загрузки IP-интерфейсов
на маршрутизаторах Cisco Routers.

Технические советы.

Балансировка загрузки IP-интерфейсов на маршрутизаторах Cisco Routers.

Основы маршрутизации для IP-сетей в случае одинаковых путей.

Вопрос: У меня четыре равных по стоимости параллельных пути к одному и тому же месту назначения. Я произвожу быструю коммутацию на двух линиях связи и коммутацию процессов на двух оставшихся. Каким образом пакеты будут маршрутизироваться в такой ситуации?

Ответ: Допустим, что у нас есть четыре одинаковых по стоимости пути к некоему блоку IP-сети. Интерфейсы 1 и 2 быстро коммутируются, 3 и 4 - нет. Маршрутизатор будет производить следующие действия:

Создайте список из четырех путей. Назовите их path 1, 2, 3 и 4. Когда вы делаете просмотр маршрута show ip route x.x.x.x, четыре пути "next hop" по порядку будут выводиться на экран после x.x.x.x.

Мы начнем с установки указателя, который называется interface_pointer, на интерфейс 1. Interface_pointer будет зацикливать интерфейсы и маршруты в определенном установленном порядке, например: 1-2-3-4-1-2-3-4-1 и т.д. На выходе show ip route x.x.x.x слева от "next hop" будет стоять символ "*", который указатель interface_pointer будет использовать для адреса пункта назначения, не обнаруженного в кэше. Всякий раз отработав, указатель interface_pointer продвигается к следующему интерфейсу или маршруту.

Для лучшего понимания этого вопроса, рассмотрим этот повторяющийся цикл:

Поступает пакет, предназначенный для сети, обслуживаемой четырьмя параллельными путями.

Маршрутизатор проверяет, находится ли он в кэше. (При запуске кэш пуст).

Если пакет находится в кэше, маршрутизатор направляет его на интерфейс, идентификатор которого хранится в кэше.

Или же маршрутизатор направляет его на тот интерфейс, на который указывает interface_pointer, и продвигает interface_pointer к следующему интерфейсу в списке.

Если интерфейс, на который маршрутизатор только что направил пакет, начинает работу с маршрутным кэшем, маршрутизатор заносит в кэш идентификатор интерфейса и IP-адрес пункта назначения.

Через некоторое время интерфейсы, выполняющие быструю коммутацию (маршрутного кэша), будут обслуживать весь трафик, кроме пунктов назначения, адресов которых нет в кэше.

Если есть два маршрутных кэша и два интерфейса, не внесенных в маршрутный кэш, то с 50% вероятностью можно сказать, что некэшированный объект попадет к интерфейсу, который кэширует объекты, выбирая из кэша данный пункт назначения для данного интерфейса.

Если нет интерфейсов, работающих с маршрутным кэшем, маршрутизатор обслуживает трафик по принципу циклического опроса (карусельный метод) на базисе попакетной обработки.

Поэтому:

Все интерфейсы параллельных путей должны или работать с маршрутным кэшем, или (все) не работать с ним.

Или

Вы можете дождаться, что через некоторое время все интерфейсы, работающие с кэшем, будут выполнять весь трафик.


Пример конфигурации - Инверсное мультиплексирование (Inverse Multiplexing) с помощью Многосвязного протокола "точка-точка" (Multilink PPP).

У нас есть два маршрутизатора в локальной сети Ethernet, каждый подключен с помощью четырех высокоскоростных арендуемых линий T1.

hostname RouterA

!

!

username RouterB password foobar

ip subnet-zero

multilink virtual-template 1

!

interface Virtual-Template1

ip unnumbered Ethernet0

ppp authentication chap

ppp multilink

!

interface Serial0

no ip address

encapsulation ppp

no fair-queue

ppp multilink

pulse-time 3

!

interface Serial1

no ip address

encapsulation ppp

no fair-queue

ppp multilink

pulse-time 3

!

interface Serial2

no ip address

encapsulation ppp

no fair-queue

ppp multilink

pulse-time 3

!

interface Serial3

no ip address

encapsulation ppp

no fair-queue

ppp multilink

pulse-time 3

!

interface Ethernet0

ip address 10.17.1.254 255.255.255.0

!

router rip

network 10.0.0.0

!

end

hostname RouterB

!

username RouterA password foobar

ip subnet-zero

multilink virtual-template 1

!

interface Virtual-Template1

ip unnumbered Ethernet0

ppp authentication chap

ppp multilink

!

interface Serial0

no ip address

encapsulation ppp

no fair-queue

ppp multilink

pulse-time 3

!

interface Serial1

no ip address

encapsulation ppp

no fair-queue

ppp multilink

pulse-time 3

!

interface Serial2

no ip address

encapsulation ppp

no fair-queue

ppp multilink

pulse-time 3

!

interface Serial3

no ip address

encapsulation ppp

no fair-queue

ppp multilink

pulse-time 3

!

interface Ethernet0

ip address 10.17.2.254 255.255.255.0

!

router rip

network 10.0.0.0

!

end

 

ООО "Новаком" тел./факс (343) 263-74-66 (многоканальный),   info@novacom.ru